Scheduled maintenance on 10th May, 2026 from 14:30 UTC

Incident Report for Fini AI

Resolved

The maintenance was completed at 15:40 UTC
Posted May 10, 2026 - 15:52 UTC

Update

We are continuing to investigate this issue.
Posted May 10, 2026 - 15:21 UTC

Investigating

Fini is currently undergoing scheduled maintenance estimated from 14:30 UTC to 15:30 UTC aimed at enhancing system performance and reliability. As part of this maintenance, we are also performing database optimizations to improve query efficiency, stability, and overall response times. During this time, the service may be temporarily unavailable. We apologize for the inconvenience and appreciate your patience and understanding.
Posted May 10, 2026 - 15:02 UTC
This incident affected: Dashboard, Widget, and Chat Integrations with CRMs.