Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 17, 2026 - 05:30 UTC
Update
We will be undergoing scheduled maintenance during this time.
Posted May 14, 2026 - 14:37 UTC
Scheduled
We will be going through a scheduled maintenance aimed at enhancing system performance and reliability. As part of this maintenance, we are also performing database optimizations to improve query efficiency, stability, and overall response times. During this time, the service may be temporarily unavailable. During this time, we expect partial outage/delayed response times for the requests.
Posted May 14, 2026 - 14:28 UTC
This scheduled maintenance affected: Dashboard, API, Widget, and Chat Integrations with CRMs.